System & Software Requirements for Android Development-- To develop Android applications using the code and tools in the Android SDK, you need a suitable development computer and development environment, as described below.

Supported Operating Systems:



  • Windows XP or Vista
  • Mac OS X 10.4.8 or later (x86 only)
  • Linux (tested on Linux Ubuntu Dapper Drake)

Supported Development Environments:

  • Eclipse IDE
  • Eclipse 3.3 (Europa), 3.4 (Ganymede)
  • Eclipse JDT plugin (included in most Eclipse IDE packages)
  • WST (optional, but needed for the Android Editors feature; included in most Eclipse IDE packages)
  • JDK 5 or JDK 6 (JRE alone is not sufficient)
  • Android Development Tools plugin (optional)
  • Not compatible with Gnu Compiler for Java (gcj)
  • Other development environments or IDEs
  • JDK 5 or JDK 6 (JRE alone is not sufficient)
  • Apache Ant 1.6.5 or later for Linux and Mac, 1.7 or later for Windows
  • Not compatible with Gnu Compiler for Java (gcj)

Please find the complete Ebook attached!